mifos
  1. mifos
  2. MIFOS-4630

Incorrect error message while disbursing second Loan

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: Release 2.1
    • Fix Version/s: Release 2.2.1
    • Component/s: Loan Account
    • Labels:
      None
    • Team:
      Core

      Description

      While disbursing second Loan account which was created using Loan Product with installments 'By Loan Cycle' or 'By Last Loan Amount', then incorrect error massage appears.

      REPRO:
      1. Create Loan Product with installments 'By Loan Cycle' or 'By Last Loan Amount'.
      2. Create new Loan Account using Loan Product created above.
      3. Disburse Loan.
      4. Create another Loan using the same Loan Product.
      5. Try to disburse Second Loan.

      EXPECTED RESULT:
      Error message appears saying that disbursal of second Loan with the same loan product is not allowed.

      ACTUAL RESULT:
      An incorrect error message appears: "Disbursal failed. This loan may have been disbursed elsewhere.".

        Issue Links

          Activity

          Lukasz Chudy added a comment - - edited

          Kay, could you write how should look an appropriate error message in above situation?

          Kay Chau added a comment -

          assign to me to figure out correct error msg

          Jakub Sławiński added a comment -

          Emily, what should be the correct message and isn't this related to MIFOS-5005?

          emilytucker added a comment -

          Duplicate of 5005.


            People

            • Assignee:
              emilytucker
              Reporter:
              Lukasz Chudy
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: