Transaction entries not displayed when loan is disbursed

Description

Note that I was only able to test this bug on the test server. We should repro
it on a clean build to confirm that this is a valid bug.

To Repro:
Log into Mifos
Create a loan in "pending approval" status
Navigate to loan detail page, click "Edit account status" at the top of the
page and approve the loan
Click on "disburse loan" on the detail page. Disburse the loan
Click on "Transaction History" page (located at the very bottom of the page)

Actual
Transaction History page is blank (mifos/accountAppAction.do?
method=getTrxnHistory)

Expected
Transaction History page should display the disbursal transaction. As per
the functional spec:
-->DR client’s loan (Assets) 13101 (exact GL Code to be picked from product
definition)
-->CR Cash (Assets) 11201 (Or whatever GL code the client enters for cash)

This should display on the page and be logged in the database. I'm worried
that b/c these transactions are not displaying on the page-- that they are not
being captured in the DB. QA should check this.

Finally, I tried this same test on the demo server (running v1.0)-- and the
disbursal transaction does display on the "Transaction History" page. However,
only the debit transaction is displayed. I'm hoping the CR transaction still
is captured in the DB. Both should be displayed.

If transaction entries are captured in the DB, but not displayed, we can
downgrade to a P2.

Environment

Platform: All, OS: All

Activity

Show:
aliyaw
March 25, 2008, 9:17 PM

Jeff - can you investigate this? We need to be sure that both the debit and
credit transactions are being correctly logged for disbursals. You can turn on
logging in mySQL to see all of the statements applied to the DB, if that helps
research things. I think either you or Chandi could probably look into this?
Once you know the logging behavior and if there are bugs in this area, assign
back to triage for review.

Jeff Brewster
March 27, 2008, 6:10 AM

change QA contact

Jeff Brewster
April 2, 2008, 6:22 PM

Emily,
I followed the repro steps on my local instance of mifos and did find entries in
the transaction log. Can you confirm these are the log entries you would
expect? If so, I suggest we mark this issue as "worksforme".

02/04/2008 68 1222 Loan Disbursement 1503 50000.0 - GROUPCLIENT NO_102
02/04/2008 mifos -
02/04/2008 68 1221 Loan Disbursement 11201 - 50000.0 GROUPCLIENT NO_102
02/04/2008 mifos -

emilytucker
April 2, 2008, 9:16 PM

Thanks for testing this, Jeff. What a relief- it is working now. I tested for
both flat and declining balance loans (assigned to a group) and the transaction
history page displayed properly.

Marking as "Works for me".

Jeff Brewster
April 21, 2008, 10:37 PM

verified per comments above.

Cannot Reproduce

Assignee

emilytucker

Reporter

emilytucker

Labels

None

URL

None

Story Points

None

Team

None

Scheduled For

None

Epic

None

Notify

None

productboard URL

None

Man Day Estimate

None

Components

Fix versions

Affects versions

Priority

Blocker
Configure