Cannot create additional field of 'Date' type without specifying a default value.

Description

REPRO (rev 12641):
==================
1. Log into Mifos
2. Click on Admin tab
3. Select "Define additional field"
4. Enter information to create an additional field of date type (non-mandatory
for any entity)
5. Select preview and submit

OBSERVED
=========
Blank page, additional field not created

EXPECTED
=========
Additional field of date type is created and shows up on the correct page in Mifos.

NOTES:
=======
I believe this did not work in v1.0 of Mifos when additional fields were defined
directly in the DB, however it is more prominent now that this is done through
the UI. Blank page can be very confusing.

Selenium script demonstrating issue is attached.

Environment

Platform: All, OS: All

Activity

Show:
aliyaw
June 3, 2008, 8:15 AM

This issue depends on re-enabling the date type additional field in the UI
(issue 1963).

emilytucker
December 17, 2008, 9:24 PM

Have updated the FS to remove reference to there being a "date" custom field.
We can add it back in if/when we fix these bugs.

Moving to unscheduled

Kay Chau
April 22, 2010, 11:04 PM

Jakub this is a feature we'd like you to add back in, let me know if you have questions on it

Jakub Sławiński
April 24, 2010, 12:36 PM

Resolved in r17255.

Jeff Brewster
June 19, 2010, 12:30 AM

verified creation of date additional field with and without default.

Fixed

Assignee

Jakub Sławiński

Reporter

aliyaw

Labels

None

URL

None

Story Points

None

Team

None

Scheduled For

None

Epic

None

Notify

None

productboard URL

None

Man Day Estimate

None

Components

Fix versions

Affects versions

Priority

Major
Configure