While editing loan account information for a client/group - Validation of modified fields does Not happen.

Description

Hi aliya,

The following was a discrepancy found. I wasn't sure which priority bracket this
fall in.

To Repro -

1.View a Client's/Group's information
2.click on any Loan Account
3.click on edit account information link
4.Enter invalid data in the fields.
5.system allows user to preview and submit changes.
6.changes are reflected in the account information consequently.

Expected Behaviour -
The system should not allow you to submit invalid data. There should be a
validation condition to check if the data entered is within the permissible range.

Thanks,
Nandini

Environment

Platform: All, OS: All

Activity

Show:
aliyaw
May 20, 2008, 5:55 PM

Triage comments -this can wait until after v1.1 to be fixed.

Jeff Brewster
August 16, 2008, 3:51 PM
  •  

    •  

      • Issue 2116 has been marked as a duplicate of this issue. ***

emilytucker
April 25, 2010, 4:46 AM

Please see bug Mifos-2110. Has some comments from Jeff Blue that may be the source of this bug

Jakub Sławiński
May 8, 2010, 4:18 PM

Resolved in r17410.

Jeff Brewster
May 26, 2010, 8:50 PM

confirmed now getting validation on required fields. Tested by entering values out of accepted range for interest rate and # of installments.

Fixed

Assignee

Jakub Sławiński

Reporter

nyadalam

Labels

None

URL

None

Story Points

None

Team

None

Scheduled For

None

Epic

None

Notify

None

productboard URL

None

Man Day Estimate

None

Components

Fix versions

Affects versions

Priority

Critical
Configure