Group creation fails when GroupPendingApprovalStateEnabled=false

Description

Report from Dusmant Kumar (via developer list serv):

"I encountered an error while creating a group under a centre. I am using the
mifos ver 1.2.1 and configured the "applicationConfiguration.custom.properties"
to directly update the group state to approved without "pending for approval". "

Was able to reproduce this error internally using the following repro steps:
1. Set up an new instance of v1.2.1 and set custom property
GroupPendingApprovalStateEnabled to false.
2. Created branch office, loan officer, and center.
3. For new center, clicked Add Group option.
4. Filled in required data for Group and click "submit" button. When this
proper it false, the submit button string is "approved".
5. Encounter exception.

Expected behavior: create group in approved status.

Note - I have not tried to reproduce this problem on later or earlier versions.

Attaching selenium repro scripts.

Environment

Platform: All, OS: All

Activity

Show:
Kay Chau
February 12, 2009, 9:49 PM

Won't Fix, we'll be deprecating this feature as it's not working and unlikely to
be used.

Jeff Brewster
April 14, 2009, 8:34 PM

change QA contact

Kay Chau
April 30, 2009, 6:44 PM

Added DocumentinFS keyword, should look at removing from configuring mifos page
altogether

Jeff Brewster
July 13, 2009, 8:17 PM

won't fix.

Kay Chau
December 19, 2010, 5:10 AM

this has been documented in configuration that it will be deprecated. Another issue is out there for deprecating in F. Removing label

Won't Fix

Assignee

mifostriage

Reporter

Jeff Brewster

Labels

None

URL

None

Story Points

None

Team

None

Scheduled For

None

Epic

None

Notify

None

productboard URL

None

Man Day Estimate

None

Components

Fix versions

Affects versions

Priority

Critical
Configure