Loan pages not encoded properly when Mifos is deployed on Windows

Description

Only tested with FR so far, but the Create and View Loan Account pages have display issues. The pages are showing up with the extended characters garbled. For example, "Résumé de compte" instead of "Résumé de compte".

I've reproduced this on two different Windows environments.

Environment

Windows, testing with FR

Activity

Show:
Adam Monsen
December 13, 2010, 10:14 PM
Edited

I don't think that's the problem. .po files are transformed into Java .properties files with iso-8859-1 encoding before they are used by Mifos.

I recall that we expect some Java .properties resource bundles to be in UTF-8 format (see application/src/main/resources/org/mifos/config/resources/messageSourceBean.xml). This might be a problem if any of the transformed .po files are forced to be interpreted as UTF-8.

Jeff Brewster
December 13, 2010, 11:20 PM

assigning to hot fix.

Kay Chau
February 7, 2011, 10:10 PM

enda uses Linux, we can defer to G until we find a customer that's deploying off of Mifos using non-English

keithwoodlock
May 17, 2011, 5:53 PM

I am seeing this still on windows. Basically its looks like the properties files themselves are not getting encoded correctly on windows (most likely when checking out using git) Its not a UTF-8 issue in rendering of the page.

Adam Monsen
May 23, 2011, 10:08 PM

Sorry, I'm not sure what to do about this, and I don't have a Windows Mifos build environment with which to debug. Reassigning to "Unassigned".

Assignee

Unassigned

Reporter

Jeff Brewster

Labels

URL

None

Story Points

0

Team

Core

Scheduled For

Release

Epic

None

Notify

None

productboard URL

None

Man Day Estimate

None

Components

Fix versions

Affects versions

Priority

Major
Configure