Error page with stack trace appears after entering chars into number field on Question Group page during Savings account creation

Description

There is an error page with stack trace appears after entering chars into number field on Question Group page during Savings account creation.

Repro:
1. Login to Mifos.
2. Create/use Question Group with number field.
2. Go to 'Clients & Accounts' tab.
3. Click on 'Create new Savings account' link.
4. Select Client and Loan product.
5. Fill all necessary fields.
6. On Question Group page, enter chars into number field and see that validation is working good.
7. Leave number field empty or with numbers and click 'Continue' button.
8. On Preview page click on 'Edit additional information' link.
9. On Question Group page, enter again chars into number field.
10. Click 'Continue' button.

Expected result:
Validation message appears and user is not able to continue.

Actual result:
There is no validation message appears. User can continue and on the next page when click 'Submit for approval' button, then error page with stack trace appears. See attached screenshot.

Environment

None

Activity

Show:
Kay Chau
March 23, 2011, 8:16 PM

Might have been introduced during conversion to FTL, can you take a look

Mifos Hudson Jira Plugin User
September 23, 2011, 11:01 AM

Integrated in

head-g-release-secondary #142
MIFOS-4900: Fixed by adding validation to the edit steps for both question groups and account details.

Rafal Lewandowski :
Files :

  • userInterface/src/main/java/org/mifos/ui/core/controller/CreateSavingsAccountFormBean.java

Rafal Lewandowski
September 23, 2011, 11:11 AM

Added validation to the edit question groups webflow step.
As the same issue has been detected with editing account details step, validation for it was provided as well.

Mifos Hudson Jira Plugin User
September 25, 2011, 8:06 AM

Integrated in

head-master-secondary #509
MIFOS-4900: Fixed by adding validation to the edit steps for both question groups and account details.

Rafal Lewandowski :
Files :

  • userInterface/src/main/java/org/mifos/ui/core/controller/CreateSavingsAccountFormBean.java

Lukasz Chudy
October 4, 2011, 1:40 PM

Verified on 04.10.2011
Bug has been fixed properly.

Assignee

Rafal Lewandowski

Reporter

Lukasz Chudy

Labels

None

URL

None

Story Points

None

Team

Core

Scheduled For

None

Epic

None

Notify

None

productboard URL

None

Man Day Estimate

None

Components

Fix versions

Affects versions

Priority

Minor
Configure