Error page with stack trace appears after entering chars into number field on Question Group page during Savings account creation

Description

There is an error page with stack trace appears after entering chars into number field on Question Group page during Savings account creation.

Repro:
1. Login to Mifos.
2. Create/use Question Group with number field.
2. Go to 'Clients & Accounts' tab.
3. Click on 'Create new Savings account' link.
4. Select Client and Loan product.
5. Fill all necessary fields.
6. On Question Group page, enter chars into number field and see that validation is working good.
7. Leave number field empty or with numbers and click 'Continue' button.
8. On Preview page click on 'Edit additional information' link.
9. On Question Group page, enter again chars into number field.
10. Click 'Continue' button.

Expected result:
Validation message appears and user is not able to continue.

Actual result:
There is no validation message appears. User can continue and on the next page when click 'Submit for approval' button, then error page with stack trace appears. See attached screenshot.

Environment

None

Status

Assignee

Rafal Lewandowski

Reporter

Lukasz Chudy

Labels

None

Implementation Priority

None

URL

None

Story Points

None

Team

Core

Scheduled For

None

50% Estimate

None

90% Estimate

None

Deployment

None

Epic

None

Request Type

None

Requestor

None

Number of Support Tickets

None

Customer

None

Notify

None

productboard URL

None

Components

Fix versions

Affects versions

Release 2.2

Priority

Minor
Configure