Not able to disburse the Client's loan if charges attached to that loan is transfered from Savings account

Description

Test Data:
Disburse Loan on 15 August 2013.
Pre-Condition:
1.Create a loan product with the following datasets.
Currency: US Dollar
Decimal Places: 2
Currency in multiples of: 0
Principal: 1000
No. Of Repayments: 12
Repaid Every: 1 month
Nominal interest rate %: 1 per month
Amortization: Equal Installments
Interest method: Declining Balance
Interest calculation period: Same as repayment period
Repayment strategy: Mifos style.

2. Create 1 Saving Product with the following datasets.
Product: Salary Acc
Currency: US Dollar
Nominal annual interest rate %: 3%
Interest compounding period: Daily
Interest posting period: Monthly
Interest calculated using: Daily Balance
No. Days in Year: 365 Days.
3. Create 2 charges
eg. Charge At Disbursement: 10
Charge after some time: 25 on 01 September 2013.
and "Charge payment by" : Account Transfer mode.

Description:
1. Create a client and assign savings and loan product to that client.
2. while submitting the new loan application in "Link savings Account:" filed enter the created savings account details and apply charges as mentioned above. (Submitted on 15 August 2013 and Expected disbursement on same date)
3. Click on Approve -> Disburse the loan on 15 August 2013.

Expected Result:
Loan should get disbursed on 15 August 2013.

Actual Result:
Not able to disburse the loan since error message is displayed as "No connection Verify Application is running".
Screen shots are attached for clarity.

Environment

None

Assignee

SSN

Reporter

SSN

Labels

None

URL

None

Story Points

None

Team

None

Notify

None

productboard URL

None

Components

Fix versions

Affects versions

Priority

Minor
Configure